Monitoring

Icinga2 – SSL Fehler beim Check check_netscaler.pl

Während der Check an der Command Line funktioniert, schlägt dieser in der Oberfläche mit obigen Fehler fehl. Dieser betrifft OpenSSL und dessen Umgang mit "unsafe legacy renegotiation". Abhilfe schafft hier eine Anpassung in der openssl.conf. Ist zwar weniger empfohlen, funzt jedoch. Einfach folgende Zeilen in der Konfiguration ergänzen. vi /etc/ssl/openssl.conf

Icinga2 – SSL Fehler beim Check check_netscaler.pl Weiterlesen »

Windows Checks

check_AD_Account Um rechtzeitig alarmiert zu werden, bevor ein AD Account abläuft, wird dieser Check verwendet. Dazu das PowerShell-Script lotp_check_ad_accounts.ps1 in den Scripts Ordner kopieren und folgende Zeilen in der nsclient.ini hinzufügen und den Dienst NSClient neu starten. Jetzt wird über den Icinga Director der entsprechende NRPE Check angelegt. Folgende Argumente müssen an dieser Stelle übergeben

Windows Checks Weiterlesen »

Icinga2 Debian 12 Installation

Installation Icinga per Hand Vorbereitung der DB apt install mariadb-server -y mysql_secure_installation !!! danger "Wichtig" Bei der Frage, ob für root die Unix Authentifizierung aktiviert werden soll, unbedingt y für Ja eingeben. mysql -- Erstellen der Icinga-DB create database icingadb ; create user 'icingadb'@'localhost' identified by 'icingadb'; grant all privileges on icingadb.* to 'icingadb'@'localhost'; --

Icinga2 Debian 12 Installation Weiterlesen »

Automatischer Neustart von Windows Diensten durch Icinga2

Das mit Icinga2 Windows Dienste überwacht werden ist nichts neues. Es gibt aber auch Dienste welche aufgrund der Systemumgebung oder "schlechter" Programmierung von Zeit zu Zeit abstürzen. Da wäre es doch eine coole Sache wenn unser Monitoring im Fehlerfall den Dienst automatisiert neu starten könnte. Dazu sind die folgenden Schritte notwendig. /usr/lib64/nagios/plugins/restart_win_service.sh Im Icinga Director

Automatischer Neustart von Windows Diensten durch Icinga2 Weiterlesen »

Update Icingaweb2

Wer Module wie Businessprocess oder ähnlich verwenden möchte, kommt um ein Update von Icingaweb2 nicht herum. Da ich beim OS auf Rockylinux 8.x setze, muss ich leider auf ein Update aus den offiziellen Repositories verzichten. Diverse Abhängigkeiten können nicht aufgelöst werden. Daher habe ich mir folgendermaßen selbst geholfen. Das Wichtigste ist ein Backup für alle

Update Icingaweb2 Weiterlesen »